IP Networks


Planning, designing, configuring, troubleshooting, and monitoring customer LAN networks, such as:

In this type of project, I am able to install routers and switches for small and large companies. My biggest undertaking was a company that had over 200 branches and would frequently open new ones. Meaning that I had to plan networks and their resources and future-proof them for new branches that would open up.


These are examples of configuration templates for routers and switches for the customer:

Router Configurations

! Enable SSH access
ip domain-name kenny-savillon.jimdofree.com/
crypto key generate rsa modulus 2048
username admin privilege 15 secret your_password
line vty 0 4
 transport input ssh telnet
 login local

! Configure interface connected to the switch as trunk port
interface GigabitEthernet0/1
description To_Switch_GE1/0/24
 no ip address
 duplex auto
 speed auto
 no shutdown
!
interface GigabitEthernet0/1.10
 description Data_VLAN
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
!
interface GigabitEthernet0/1.20
 description Voice_VLAN
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
!
interface GigabitEthernet0/1.30
 description Management_VLAN
 encapsulation dot1Q 30
 ip address 192.168.30.1 255.255.255.0
!
! Enable DHCP for VLAN 10 (Data_VLAN)
ip dhcp pool DATA
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.1
 dns-server 8.8.8.8
!
! Enable DHCP for VLAN 20 (Voice_VLAN)
ip dhcp pool VOICE
 network 192.168.20.0 255.255.255.0
 default-router 192.168.20.1
 dns-server 8.8.8.8
!
! Enable NAT for VLAN 10 (Data_VLAN)
ip nat inside source list NAT_ACL interface GigabitEthernet0/1.10 overload
!
access-list 1 permit 192.168.10.0 0.0.0.255

interface GigabitEthernet0/0
 description WAN-to-ISP
 ip address 10.0.0.2 255.255.255.252
 no shutdown

! Configure BGP
router bgp 28000
 neighbor 10.0.0.1 remote-as 36000
 neighbor 10.0.0.1 description ISP_Peer
 neighbor 10.0.0.1 update-source GigabitEthernet0/0
 !
 address-family ipv4
  network 192.168.10.0 mask 255.255.255.0
  network 192.168.20.0 mask 255.255.255.0
  network 192.168.30.0 mask 255.255.255.0
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 default-originate
 exit-address-family

! Configure default route to ISP
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0


! Enable SNMP for monitoring
snmp-server community public RO

Switch Configurations

! Enable SSH access
ip domain-name kenny-savillon.jimdofree.com/
crypto key generate rsa modulus 2048
line vty 0 4
transport input ssh telnet

! Configure VLANs
vlan 10
 name Data_VLAN
vlan 20
 name Voice_VLAN

! Configure interface specific settings
interface GigabitEthernet1/0/1
 description Data_Port_1
 switchport mode access
 switchport access vlan 10

interface GigabitEthernet1/0/2
 description Data_Port_2
 switchport mode access
 switchport access vlan 10

interface GigabitEthernet1/0/3
 description Voice_Port_1
 switchport mode access
 switchport access vlan 20
 spanning-tree portfast

interface GigabitEthernet1/0/4
 description Data_Port_3
 switchport mode access
 switchport access vlan 10


! Configure trunk port for uplink
interface GigabitEthernet1/0/24
description To-Router-GE0/1
 switchport mode trunk
 switchport trunk allowed vlan all

! Configure management interface
interface Vlan30
 ip address 192.168.30.2 255.255.255.0
 no shutdown

! Set default gateway
ip default-gateway 192.168.30.1

! Disable unused interfaces
interface range GigabitEthernet1/0/25-48
 shutdown

! Enable Port Security on used interfaces
interface range GigabitEthernet1/0/1-4
 switchport port-security
 switchport port-security maximum 2
 switchport port-security violation restrict

! Configure SNMP for monitoring
snmp-server community public RO


Objectives

IP Networks had the objective of bringing customer networks under one fully packaged service. By having an experienced network engineer managing and supporting their network, customers benefited from my accumulated knowledge, best practices, and problem-solving abilities. This expertise led to cost-effective solutions as issues could be addressed swiftly, network downtime could be minimized, and network resources could be utilized efficiently. Ultimately, it provided customers with peace of mind, knowing that their network was in capable hands.


My Role

My role was to:

  • Plan and schedule implementation dates and deadlines.
  • Analyze business requirements and design network architectures that met the customers needs.
  • Deploy and configure network hardware and software components. This included setting up routers, switches, firewalls, wireless access points, and other network devices.
  • Troubleshooting, in cooperation with other roles such as customer support, field teams, and core network teams.
  • Document network configurations, diagrams, and procedures.
  • Plan and execute network upgrades and ensure smooth transitions to new network architectures.

Technologies and Vendors

These are some of the vendors and technologies that I had experience working with:




  • BGP
  • OSPF
  • EIGRP
  • RIP
  • Static Routing
  • MPLS
  • Vlans
  • Switching
  • Trunking
  • Bridging
  • Port Security
  • Spanning Tree
  • VPN
  • DNS
  • SNMP
  • DHCP
  • NAT
  • SMTP
  • POP
  • IPv4
  • IPv6
  • TCP
  • UDP
  • ARP
  • PING
  • ICMP
  • MAC ADDRESS
  • CISCO OS
  • CLI
  • JUNOS
  • Solarwinds
  • Packet Tracer
  • WireShark
  • PRTG
  • Whats Up Gold
  • Cacti